Error when I run build-linux.sh in the new release 6.2.0

Hi,

I get the following error when I try compile any example scenario in src folder using build-linux.sh.
I never got it in the previous version.

../lib/CommonDataModel.so: undefined reference to `typeinfo for std::thread::_State@GLIBCXX_3.4.22'
../lib/CommonDataModel.so: undefined reference to `std::thread::_M_start_thread(std::unique_ptr >, void (*)())@GLIBCXX_3.4.22'
../lib/CommonDataModel.so: undefined reference to `std::thread::_State::~_State()@GLIBCXX_3.4.22'
collect2: error: ld returned 1 exit status

Any help will be appreciated.

Platform: Ubuntu 16.04.04 g++ 5.4.0

Thanks,
Farooq

Comments

  • abairdabaird Moderator
    We tested on Ubuntu 17.04, but I just tried running the build script on a virtual machine with your environment and got the same error as you, we are working on it now, will probably have it fixed today. I'll be sure to keep you updated

    Thanks Farooq!
  • abairdabaird Moderator
    Hi Farooq

    I tested and ran on Ubuntu 16.04 with some fixes in place ( I think there was an issue with the states folder) so I basically re-gened the states folder and zipped it up again (not before building and testing it, I was able to run a test mechanical ventilation how to). I just emailed it to you but the zipped folder is 22 mb so I'm not sure if the attachment will reach you.

    If it doesn't get to you, you can actually build the sdk by cloning the source via github, then building it manually. It shouldn't involve too much.

    You can clone this from here: https://github.com/BioGearsEngine/Engine

    Then follow the build instructions for linux. Once you've build everything, in the /src folder just run 'ant genStates' Then Navigate to BioGears/src. Deploy the SDK by running:

    ./deploy-linux-library.sh x64

    Don't forget to include the x64 parameter. After running this the SDK files will be placed in the BioGears/library folder

    Build the sdk by navigating to BioGears/library/src and running:

    ./build-linux.sh

    This will place the resulting executable in the BioGears/library/bin directory. Test that this executable works by navigating to this directory and running:

    ./BioGearsEngineHowTo

    If these steps don't work for you (just tested it on my virtual machine and everything seemed to be working just fine) AND you can't get the zip I just emailed you, then I'll just update this thread when the zipped download is updated, should be by tomorrow or Thursday.

    Thanks for helping out by flagging this bug, we really appreciate it!

    Austin Baird
    BioGears PI
    mousalgf
Sign In or Register to comment.