Getting Started

I've been loading the GUI through the BioGearsGUI.jar file on my Ubuntu Linux computer from the terminal. The GUI comes up and I'm able to load the scenario and execute; however, whenever I try to get the results filename/showcase/CombatMultitraumaResults does not exist or is not a directory. I pulled the xml file for CombatMultitraumaResults and it comes up in my browser just fine.

Other info:

I've tried running the .bat BioGearsGUI file from WINE, but that has similar issues to another thread I read on here, where a terminal will pop up then my current terminal spits out an error message and the GUI doesn't even pop up.

I am currently using the BioGearsTK.

Thanks for looking into this!

Comments

  • abrayabray Entry Level
    I believe the windows issues is due to not being able to find java on your path.
    Can you give me the specific error?
    You can also modify the batch file to run java.exe rather than javaw.exe. This will my give more information.

    As for the linux issue, Do you get the INFO messages about Computed the Patient Maximum Heart Rate and the Converging System messages?
  • I get the following on the GUI when I load the CombatMultitrauma scenario:
    Opening CombatMultitrauma.xml...
    When I click execute nothing appears on the GUI about Computed the Patient Max Heart Rate, etc.
  • abrayabray Entry Level
    Have you tried running the BioGearsGUI.sh script on Linux? It should set some path information to find all the appropriate libraries and config files.
  • I'll try that. Also this is the error I get whenever I try to execute the .bat on wine:

    Z:\home\ryan\NetBeansProjects\NewBioGears\toolkit>start BioGearsGUI.bat
    fixme:exec:SHELL_execute flags ignored: 0x00000100

    Z:\home\ryan\NetBeansProjects\NewBioGears\toolkit>fixme:findstr:wmain stub: L"findstr" L"64-Bit"
    fixme:exec:SHELL_execute flags ignored: 0x00000100
  • I just running the .sh file and I got the same error as when I was running the .jar. I can send all of the terminal data I receive when I click execute, but it's kind of lengthy.
  • abrayabray Entry Level
    Go ahead and post it here.
  • Exception in thread "AWT-EventQueue-0" java.lang.UnsatisfiedLinkError: /home/ryan/NetBeansProjects/NewBioGears/toolkit/x64/BioGearsEngineJNI.so: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /home/ryan/NetBeansProjects/NewBioGears/toolkit/x64/BioGearsEngine.so)
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1910)
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1795)
    at java.lang.Runtime.load0(Runtime.java:809)
    at java.lang.System.load(System.java:1080)
    at mil.tatrc.physiology.biogears.engine.BioGears.(BioGears.java:115)
    at mil.tatrc.physiology.biogears.engine.BioGearsScenarioExec.(BioGearsScenarioExec.java:14)
    at mil.tatrc.physiology.biogears.gui.scenario.ScenarioCalcDisplay.
  • I have other error data, but that's the beginning of it
  • abrayabray Entry Level
    It sounds like you may not have the latest version of some C++ runtime libraries on your linux box

    The accepted answer here:
    http://askubuntu.com/questions/575505/glibcxx-3-4-20-not-found-how-to-fix-this-error

    It suggests some commands to run to make sure you have all the libraries you need to run.
    Maybe just try the : sudo apt-get install libstdc++6
    and see if that helps
  • OOOhhh. Thanks so much. Will do that, I just got this laptop and completely forgot that it didn't have C++ on it.
  • abrayabray Entry Level
    No problem, let me know if you run into any other issues or have any other questions or comments!
  • Okay, that fixed the execute button; however, I'm still running into issues with data retrieval. I don't think that's it's pulling the data from the Multitrauma file. The graph that shows up is empty, and I'm still getting errors on my terminal when I try to pull the results.

    Exception in thread "AWT-EventQueue-0" java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
    at java.util.ArrayList.rangeCheck(ArrayList.java:638)
    at java.util.ArrayList.get(ArrayList.java:414)
    at mil.tatrc.physiology.biogears.gui.scenario.ResultsWindow.(ResultsWindow.java:127)

    By the way, thanks for all the quick responses!
  • abrayabray Entry Level
    Can you try running another scenario or two and see if those give you the same result.
    I will check the code to see if I can see anything associated with the results window.
  • It's creating the directories for the results, but I'm not getting any data when I execute it. The graphs always come up empty still after trying the asthma simulation.
  • abrayabray Entry Level
    I can see an issue with our code not checking for an empty results directory.
    It takes about 3-5 minutes for the system to start producing results as it stabilizes the system specified in the scenario.
    That is where you should see the messages I mentioned earlier.
    It sounds like either the engine is crashing before any results are created, or you are stopping the simulation during the initialization.
    Then when you click on the Results button in the GUI, and there are no results, you will get this crash because it did not find any *.jpg plots in the expected directory, and the code was written with the assumption that there will always be jpgs in that folder.

    Long story short, are you seeing stabilization info messages when you execute? After it stablilizes you will see live plots.
  • I'm sorry, I didn't realize it took a couple minutes. My fault. Thanks!
Sign In or Register to comment.